서브넷팅

192.168.10.0/25
192.168.10.128/25


Router - PC처럼 설정하기 (hostname과 IP 바꿔서 나머지도)

!
en
!
conf t
!
##################################################
ho PC3
##################################################
ip domain-name netsec.kr
no ip domain-lookup
!
no ip routing
!
line console 0
exec-timeout 0
exit
!
int e0/0
##################################################
ip add 192.168.10.1 255.255.255.128
##################################################
no shutdown


Switch - SW1 기본 설정 (hostname만 바꿔서 SW2도)

!
en
!
conf t
##################################################
ho SW1
##################################################
ip domain-name netsec.kr
no ip domain-lookup
!
banner motd ^
NETSEC-SW1
^
!
username user01 secret cisco
username admin privilege 15 secret cisco
!
line console 0
 exec-timeout 0
 logging sync
 login local
 exit
!
line vty 0 4
 exec-timeout 0
 logging sync
 transport input ssh
 login local
 exit
!
ip ssh time-out 30
ip ssh version 2
crypto key generate rsa general-keys modulus 1024
!

exit
copy running-config startup-config


Switch - 필요한 인터페이스 빼고 shutdown

int range ethernet 0/0 - 3,1/0 - 3,2/0 - 3,3/0 - 3
shutdown
!
int range ethernet 0/0 - 1,1/1
no shutdown


Switch - VLAN access 설정 (여러가지 수정해서 SW2도 적용)

!
do show vlan brief
int e0/0
desc VLAN100-PC3
switchport mode access
switchport access vlan 200
no shutdown
!
int e0/1
desc VLAN200-PC4
switchport mode access
switchport access vlan 100
no shutdown
!
do show vlan brief
!
!trunk
int e1/1
desc trunk-vlan100-vlan200
shutdown
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 100,200
switchport nonegotiate
no shutdown
end
!
show interfaces trunk
!

'IT > Network Theory' 카테고리의 다른 글

Static Routing의 올바른 사용법  (0) 2021.09.06
IGP - Distance Vector - RIPv2  (0) 2021.09.06
Routing Concept & Static Routing  (0) 2021.09.03
Routing Lab Compilation  (0) 2021.09.03
Lab - Network Subnetting on 3 Routers  (0) 2021.09.02

VLAN이란 필연적으로 일어나는 수많은 브로드캐스트에 의해 모든 장비들이 L3의 Packet 부분까지 데이터를 Decapsulation하고 다시 Encapsulation해서 내려 보내는 과정이 반복되어 네트워크의 성능이 저하되는 것을 방지하기 위해 브로드캐스트 도메인을 여러 개로 분리하는 것이다. 

 

하나의 LAN을 여러 개의 VLAN으로 쪼개고 나면 서로 다른 VLAN에 있는 장비끼리는 MAC Address 브로드캐스트 통신이 불가능하게 된다. 통신하려면 3계층 장비인 라우터 또는 멀티레이어 스위치를 연결해 IP를 통해서 할 수 있다.

 

VLAN은 VLAN ID로 구분되며, 0~4095로 4096(2^12)개의 구분 번호가 존재한다.

이 중에 0번과 4095번은 예약되어 있고, 1 = Default VLAN, 1002, 1004 = FDDI용 예약, 1003, 1005 = Token-ring 예약이기 때문에 실제 가용 범위는 1~4094(상기 예약 ID 제외)이다.

 

Switch에서는 Port 별로 각각의 VLAN 그룹에 소속시켜 운영한다.

 


명령어

 

VLAN 확인 명령어

SW#show vlan brief

 

VLAN 생성 명령어 1 : VLAN Database Mode(비권장)

SW#vlan database

SW(vlan)#vlan 10

 

1~1024 까지만 생성 가능

각 VLAN 별 설정 불가능

 

VLAN 생성 명령어 2 : VLAN Global Configuration Mode(권장)

SW#conf t

SW(config)#vlan 30

SW(config-vlan)#name netsec

SW(config-vlan)#exit

 

1~4094까지 생성 가능

각 VLAN 별 설정 가능

 


 

switchport mode access

Access : 스위치의 포트와 종단 장치를 연결하는 것.

Access는 스위치의 네트워크 인터페이스와 End-User Device를 연결하는 것이다.

Trunk : 스위치끼리 연결하는 것

Trunk는 논리적으로 하나의 스위치를 만드는 것, 모든 VLAN에 대한 통로라고도 볼 수 있으며, 기존에 있던 스위치를 그대로 사용하며 확장하기 때문에 비용적으로 효율성이 있다.

 

 

라우터(PC)에 IP주소 부여하기

 

R1

R1(config)#no ip routing(라우터를 PC처럼 쓰기)

R1(config)#int e0/0

R1(config-if)#ip add 192.168.10.1 255.255.255.0

R1(config-if)#no shutdown

R2

R2(config)#no ip routing

R2(config)#int e0/0

R2(config-if)#ip add 192.168.10.2 255.255.255.0

R2(config-if)#no shutdown

 

 

Switch Trunk 구성 단계

 

1. Interface Configurtion Mode 진입

 

2. Interface shutdown

Switch(config-if)#shutdown

 

3. Encapsulation 방식을 선택한다(802.1Q, ISL)

Switch(config-if)#switchport trunk encapsulation dot1q

 

4. Layer 2 Trunk 설정

Switch(config-if)#switchport mode trunk

 

5. 필요에 따라 Native VLAN을 설정(802.1Q) : VLAN을 식별하는 태그 없이 Trunk를 통과할 수 있음.

Switch(config-if)#switchport trunk native vlan 1

 

6. Trunk 구간에 허용할 VLAN 지정

Switch(config-if)#switchport trunk allowed vlan 10,20

 

7. Interface를 no shutdown해서 Trunk 활성화

Switch(config-if)#no shutdown

 

8. Trunk 설정 검증

Switch(config-if)#end

Switch#show interfaces trunk

 

 

 

VLAN 관련 config 포스팅 : https://yoonhoji.tistory.com/30

'IT > Network Theory' 카테고리의 다른 글

Lab - Network Subnetting on 3 Routers  (0) 2021.09.02
MAC Table in Switch  (0) 2021.09.01
IT 관련 용어 사전 사이트  (0) 2021.09.01
SPOF(Single Point Of Failure)  (0) 2021.09.01
Connection between Serial Interfaces  (0) 2021.08.31

+ Recent posts